import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!\\s)\\*(?!\\s)(?:(?:[^\\*\\*]*(?:(?:\\*\\*[^\\*\\*]*){2})+?)+?|[^\\*\\*]+?)(?<!\\s)\\*)|((?<!\\s)\\*\\*(?!\\s)(?:[^\\*]+?|(?:[^\\*]*(?:(?:\\*[^\\*]*){2})+?)+?)(?<!\\s)\\*\\*)";
final String string = "text *no match* text\n"
+ "text*italic*text\n"
+ "text**bold**text\n"
+ "text***italic&bold***text\n"
+ "text*italic**bold&italic***text\n"
+ "text**bold*bold&italic***text\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}