re = /((?<!\s)\*(?!\s)(?:(?:[^\*\*]*(?:(?:\*\*[^\*\*]*){2})+?)+?|[^\*\*]+?)(?<!\s)\*)|((?<!\s)\*\*(?!\s)(?:[^\*]+?|(?:[^\*]*(?:(?:\*[^\*]*){2})+?)+?)(?<!\s)\*\*)/
str = 'text *no match* text
text*italic*text
text**bold**text
text***italic&bold***text
text*italic**bold&italic***text
text**bold*bold&italic***text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end