const regex = /((?<!\s)\*(?!\s)(?:(?:[^\*\*]*(?:(?:\*\*[^\*\*]*){2})+?)+?|[^\*\*]+?)(?<!\s)\*)|((?<!\s)\*\*(?!\s)(?:[^\*]+?|(?:[^\*]*(?:(?:\*[^\*]*){2})+?)+?)(?<!\s)\*\*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<!\\s)\\*(?!\\s)(?:(?:[^\\*\\*]*(?:(?:\\*\\*[^\\*\\*]*){2})+?)+?|[^\\*\\*]+?)(?<!\\s)\\*)|((?<!\\s)\\*\\*(?!\\s)(?:[^\\*]+?|(?:[^\\*]*(?:(?:\\*[^\\*]*){2})+?)+?)(?<!\\s)\\*\\*)', 'g')
const str = `text *no match* text
text*italic*text
text**bold**text
text***italic&bold***text
text*italic**bold&italic***text
text**bold*bold&italic***text
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}