using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\d*M(\+|\-)\d*(([A-Z]\d*)+)\]((\+|\-)|\d+(\+|\-))";
string input = @"[12M+4NH3]3+
[M-H]1-
[M-H]-";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}