// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\d*M(\+|\-)\d*(([A-Z]\d*)+)\]((\+|\-)|\d+(\+|\-))").unwrap();
let string = "[12M+4NH3]3+
[M-H]1-
[M-H]-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}