const regex = /\[\d*M(\+|\-)\d*(([A-Z]\d*)+)\]((\+|\-)|\d+(\+|\-))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\d*M(\\+|\\-)\\d*(([A-Z]\\d*)+)\\]((\\+|\\-)|\\d+(\\+|\\-))', 'g')
const str = `[12M+4NH3]3+
[M-H]1-
[M-H]-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}