package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^@]{0,1}(@[a-zA-z\d]+)`)
var str = `@test1 стоп, не так все
@test1 не знаю даже @test1 тест@test1привет @@test1р
Привет, р ебят @test2 как дела? @test1 @test2@test1
@test1п`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}