use strict;
my $str = '@test1 стоп, не так все
@test1 не знаю даже @test1 тест@test1привет @@test1р
Привет, ребят @test2 как дела? @test1 @test2@test1
@test1п';
my $regex = qr/[^@]{0,1}(@[a-zA-z\d]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}