#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Vuln\h+:\h+Upgrade\h+(?P<pypi>\S+)\h+from\h+(?P<ini_v>[0-9.]+)\h+to\h+(?P<final_v>[0-9.]+\h+Final)"
Local $sString = "Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final" & @CRLF & _
"Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final for github.com/blah/blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")