import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Vuln\\h+:\\h+Upgrade\\h+(?P<pypi>\\S+)\\h+from\\h+(?P<ini_v>[0-9.]+)\\h+to\\h+(?P<final_v>[0-9.]+\\h+Final)";
final String string = "Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final\n"
+ "Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final for github.com/blah/blah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}