re = /^Vuln\h+:\h+Upgrade\h+(?P<pypi>\S+)\h+from\h+(?P<ini_v>[0-9.]+)\h+to\h+(?P<final_v>[0-9.]+\h+Final)/m
str = 'Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final
Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final for github.com/blah/blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end