const regex = /^(?:(?:\d+(?:\.\d+)?),){2}(\d+(?:\.\d+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\d+(?:\\.\\d+)?),){2}(\\d+(?:\\.\\d+))', 'gm')
const str = `1.55763239875389,2.80373831775701,1.24610591900312,4.04984423676012,26.4797507788162,2.49221183800623,299`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}