#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ALARM: .*'Switch Sensor 2'"
Local $sString = "20:18:16 2024/08/22 PDU INFO:" & @CRLF & _
"errorstatus 0" & @CRLF & _
"transactionid 20" & @CRLF & _
"version 1" & @CRLF & _
"notificationtype TRAP" & @CRLF & _
"receivedfrom UDP: [192.168.0.123]:57381->[192.168.1.200]:162" & @CRLF & _
"messageid 0" & @CRLF & _
"requestid 1" & @CRLF & _
"community ultra_violet" & @CRLF & _
"errorindex 0" & @CRLF & _
"VARBINDS:" & @CRLF & _
"iso.3.6.1.2.1.1.3.0 type=67 value=Timeticks: (2341303) 6:30:13.03" & @CRLF & _
"iso.3.6.1.6.3.1.1.4.1.0 type=6 value=OID: iso.3.6.1.4.1.20916.1.12.2.1" & @CRLF & _
"iso.3.6.1.4.1.20916.1.12.2.1.0 type=4 value=STRING: "ALARM: Switch Open Alarm on Sensor 'Switch Sensor 2'""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")