import Foundation
let pattern = #"ALARM: .*'Switch Sensor 2'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
20:18:16 2024/08/22 PDU INFO:
errorstatus 0
transactionid 20
version 1
notificationtype TRAP
receivedfrom UDP: [192.168.0.123]:57381->[192.168.1.200]:162
messageid 0
requestid 1
community ultra_violet
errorindex 0
VARBINDS:
iso.3.6.1.2.1.1.3.0 type=67 value=Timeticks: (2341303) 6:30:13.03
iso.3.6.1.6.3.1.1.4.1.0 type=6 value=OID: iso.3.6.1.4.1.20916.1.12.2.1
iso.3.6.1.4.1.20916.1.12.2.1.0 type=4 value=STRING: "ALARM: Switch Open Alarm on Sensor 'Switch Sensor 2'"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)