$re = '/ALARM: .*\'Switch Sensor 2\'/m';
$str = '20:18:16 2024/08/22 PDU INFO:
errorstatus 0
transactionid 20
version 1
notificationtype TRAP
receivedfrom UDP: [192.168.0.123]:57381->[192.168.1.200]:162
messageid 0
requestid 1
community ultra_violet
errorindex 0
VARBINDS:
iso.3.6.1.2.1.1.3.0 type=67 value=Timeticks: (2341303) 6:30:13.03
iso.3.6.1.6.3.1.1.4.1.0 type=6 value=OID: iso.3.6.1.4.1.20916.1.12.2.1
iso.3.6.1.4.1.20916.1.12.2.1.0 type=4 value=STRING: "ALARM: Switch Open Alarm on Sensor \'Switch Sensor 2\'"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);