#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\/\n]*)(\/[^\/\n]+\/)?([^\/\n]*)$"
Local $sString = "Fred Joseph /Smith/ " & @CRLF & _
"/Smith/" & @CRLF & _
"Fred Joseph" & @CRLF & _
"/Smith/ Fred Joseph" & @CRLF & _
"Fred /Smith/ Joseph"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")