using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\/\n]*)(\/[^\/\n]+\/)?([^\/\n]*)$";
string input = @"Fred Joseph /Smith/
/Smith/
Fred Joseph
/Smith/ Fred Joseph
Fred /Smith/ Joseph";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}