import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\/\\n]*)(\\/[^\\/\\n]+\\/)?([^\\/\\n]*)$";
final String string = "Fred Joseph /Smith/ \n"
+ "/Smith/\n"
+ "Fred Joseph\n"
+ "/Smith/ Fred Joseph\n"
+ "Fred /Smith/ Joseph";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}