package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b(\w+ (\s\w+)*)\b){1,20}`)
var str = `adf afeg hrh adf afe asf a`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}