const regex = /(\b(\w+ (\s\w+)*)\b){1,20}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(\\w+ (\\s\\w+)*)\\b){1,20}', '')
const str = `adf afeg hrh adf afe asf a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}