$re = '/(\b(\w+ (\s\w+)*)\b){1,20}/';
$str = 'adf afeg hrh adf afe asf a';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);