package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+$)`)
var str = `vheller@yahoo.com
edgar.jacobson@yahoo.com
plebsack@gmail.com
medhurst.elsie@homenick.com
tyler41@yahoo.com
greenholt.dorthy@gmail.com
nola11@braun.com
monte62@yahoo.com
nader.ivory@grady.net
lillie.kunde@stamm.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}