re = /(^[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+$)/m
str = 'vheller@yahoo.com
edgar.jacobson@yahoo.com
plebsack@gmail.com
medhurst.elsie@homenick.com
tyler41@yahoo.com
greenholt.dorthy@gmail.com
nola11@braun.com
monte62@yahoo.com
nader.ivory@grady.net
lillie.kunde@stamm.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end