# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+$)"
test_str = ("vheller@yahoo.com\n"
"edgar.jacobson@yahoo.com\n"
"plebsack@gmail.com\n"
"medhurst.elsie@homenick.com\n"
"tyler41@yahoo.com\n"
"greenholt.dorthy@gmail.com\n"
"nola11@braun.com\n"
"monte62@yahoo.com\n"
"nader.ivory@grady.net\n"
"lillie.kunde@stamm.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.