#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*(?:\[[^\]]*\]|\([^)]*\))\s*"
Local $sString = "WALL COLOR (IS HERE) [SHERWIN-WILLIAMS]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)