import Foundation
let pattern = #"\s*(?:\[[^\]]*\]|\([^)]*\))\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"WALL COLOR (IS HERE) [SHERWIN-WILLIAMS]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)