re = /\s*(?:\[[^\]]*\]|\([^)]*\))\s*/m
str = 'WALL COLOR (IS HERE) [SHERWIN-WILLIAMS]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result