const regex = /^(?=.*?\bApple\b)(?=.*?\bBat\b)(?=.*?\bCar\b)\w+(?:, ?\w+){2}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*?\\bApple\\b)(?=.*?\\bBat\\b)(?=.*?\\bCar\\b)\\w+(?:, ?\\w+){2}$', 'gmi')
const str = `Bat, Car, Apple
Car, Bat, Apple
Apple, Car, Bat
Apple, Car, Bat, Stick
Bat, Car
Apple
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}