re = /^(?=.*?\bApple\b)(?=.*?\bBat\b)(?=.*?\bCar\b)\w+(?:, ?\w+){2}$/mi
str = 'Bat, Car, Apple
Car, Bat, Apple
Apple, Car, Bat
Apple, Car, Bat, Stick
Bat, Car
Apple
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end