$re = '/^(?=.*?\bApple\b)(?=.*?\bBat\b)(?=.*?\bCar\b)\w+(?:, ?\w+){2}$/mi';
$str = 'Bat, Car, Apple
Car, Bat, Apple
Apple, Car, Bat
Apple, Car, Bat, Stick
Bat, Car
Apple
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);