using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^[a-zA-Z#\s]+)\d+|\d+(?=[a-zA-Z#\s]+$)";
string input = @"abc 12345678
abc12345678abc
#12345678
12345678#
12345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}