using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"end\s*(\w+(?:\s+\w+){0,2})";
string input = @"the end of the world,
the end of day,
the end here.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}