$re = '`end\s*(\w+(?:\s+\w+){0,2})`m';
$str = 'the end of the world,
the end of day,
the end here.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);