package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)end\s*(\w+(?:\s+\w+){0,2})`)
var str = `the end of the world,
the end of day,
the end here.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}