import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^\\\\])'";
final String string = "Let\\'s agree the single quotes in this sentence are already escaped, aren\\'t they?\n"
+ "'But let's also agree the ones in this sentence aren't.'\n"
+ "\\'But what's the deal with this one?\\'\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}