$re = '/(^|[^\\\\])\'/m';
$str = 'Let\\\'s agree the single quotes in this sentence are already escaped, aren\\\'t they?
\'But let\'s also agree the ones in this sentence aren\'t.\'
\\\'But what\'s the deal with this one?\\\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);