re = /(^|[^\\])'/m
str = 'Let\\\'s agree the single quotes in this sentence are already escaped, aren\\\'t they?
\'But let\'s also agree the ones in this sentence aren\'t.\'
\\\'But what\'s the deal with this one?\\\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end