const regex = /(:|,|-|\.)\1+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(:|,|-|\\.)\\1+', 'g')
const str = `ab::::c ---------d,,,e ..........f ::a-b,,,c..d`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);