use strict;
my $str = 'ab::::c ---------d,,,e ..........f ::a-b,,,c..d';
my $regex = qr/(:|,|-|\.)\1+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";