re = /(:|,|-|\.)\1+/
str = 'ab::::c ---------d,,,e ..........f ::a-b,,,c..d'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result