const regex = /^(?:https:\/\/)?(?:www\.)?website.net\/[^?\s]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https:\\\/\\\/)?(?:www\\.)?website.net\\\/[^?\\s]+', 'gm')
const str = `https://website.net/user/id/my-name-is-jeff2
https://website.net/user/id/my-name-is-jeff2?utm_source=google
website.net/article/my-name
www.website.net/book/random/he-is-jeff2
https://www.website.net/user/search/my-name-is-jeff2
https://othersite.ru/user/id/my-hame-is-jeff2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}