// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https:\/\/)?(?:www\.)?website.net\/[^?\s]+").unwrap();
let string = "https://website.net/user/id/my-name-is-jeff2
https://website.net/user/id/my-name-is-jeff2?utm_source=google
website.net/article/my-name
www.website.net/book/random/he-is-jeff2
https://www.website.net/user/search/my-name-is-jeff2
https://othersite.ru/user/id/my-hame-is-jeff2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}