re = /^(?:https:\/\/)?(?:www\.)?website.net\/[^?\s]+/m
str = 'https://website.net/user/id/my-name-is-jeff2
https://website.net/user/id/my-name-is-jeff2?utm_source=google
website.net/article/my-name
www.website.net/book/random/he-is-jeff2
https://www.website.net/user/search/my-name-is-jeff2
https://othersite.ru/user/id/my-hame-is-jeff2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end