using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Firmware\/(.*?)_update_V([\d_]+)_(\d\d)(\d\d)(\d\d)";
string input = @"https://www.eq-3.de/downloads/software/firmware/HM-ES-TX-WM_update_V2_2_190619_1.tgz";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}