$re = '/Firmware\/(.*?)_update_V([\d_]+)_(\d\d)(\d\d)(\d\d)/mi';
$str = 'https://www.eq-3.de/downloads/software/firmware/HM-ES-TX-WM_update_V2_2_190619_1.tgz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);