const regex = /Firmware\/(.*?)_update_V([\d_]+)_(\d\d)(\d\d)(\d\d)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Firmware\\\/(.*?)_update_V([\\d_]+)_(\\d\\d)(\\d\\d)(\\d\\d)', 'gmi')
const str = `https://www.eq-3.de/downloads/software/firmware/HM-ES-TX-WM_update_V2_2_190619_1.tgz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}