#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:.*\n){2}"
Local $sString = "LINE1" & @CRLF & _
"LINE2" & @CRLF & _
"LINE3" & @CRLF & _
"LINE4" & @CRLF & _
"LINE5" & @CRLF & _
"LINE6" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)