const regex = /^(?:.*\n){2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*\\n){2}', 'gm')
const str = `LINE1
LINE2
LINE3
LINE4
LINE5
LINE6
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);