const regex = new RegExp('(?:(?<=\\().+?(?=\\))|(?<=\\[).+?(?=\\]))', 'gm')
const str = `this is a [sample] string
with [so.me] special ((words)). and he(r)e's [[another! one]] within double brack[ets.
let's finish] this.
#ver 1 - \\[(.*?)\\] - catch brackets, stop if nl between brackets
#ver 2 - \\[(.*?]*)\\] - same
#ver 3 - \\[([^]]+)\\] - same, but catch even if nl between brackets
#ver 4 - \\[([^\\[\\]]*)\\] - same
#ver 5 - (?<=\\[).+?(?=\\]) - catch inside the brackets, stops at nl
#ver 6 - (\\[(?:\\[??[^\\[]*?\\])) - same as #3
#ver 7 - (?<=\\[).*?(?=\\]) - same as # 5
#ver 8 - ([[][a-z \\s]+[]]) - catch only the first, w/ brackets
#ver 9 - (?:(?<=\\().+?(?=\\))|(?<=\\[).+?(?=\\])) - same as #5 but catch () as well`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}