import Foundation
let pattern = #"(?:(?<=\().+?(?=\))|(?<=\[).+?(?=\]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
this is a [sample] string
with [so.me] special ((words)). and he(r)e's [[another! one]] within double brack[ets.
let's finish] this.
#ver 1 - \[(.*?)\] - catch brackets, stop if nl between brackets
#ver 2 - \[(.*?]*)\] - same
#ver 3 - \[([^]]+)\] - same, but catch even if nl between brackets
#ver 4 - \[([^\[\]]*)\] - same
#ver 5 - (?<=\[).+?(?=\]) - catch inside the brackets, stops at nl
#ver 6 - (\[(?:\[??[^\[]*?\])) - same as #3
#ver 7 - (?<=\[).*?(?=\]) - same as # 5
#ver 8 - ([[][a-z \s]+[]]) - catch only the first, w/ brackets
#ver 9 - (?:(?<=\().+?(?=\))|(?<=\[).+?(?=\])) - same as #5 but catch () as well
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)